JCooney.NET

Joseph Cooney's Weblog

NAVIGATION - SEARCH

Watch Me Fail to Install IE9

I recently tweeted about some problems I was having installing the IE9 beta, and the irrepressible @delic8genius and developer evangelist Michael Kordahi asked me for more info. Since an accurate description of what had transpired couldn’t fit in 140 characters I decided to screen-cast the whole episode from go to woe. Here is a rough transcript for those who think watching someone else using a computer for 7+ minutes and failing might be rather dull.

0:00 – IE9, HTML5, ECMAScript, CSS3, Cats & Dogs living together, Mass hysteria. I want in!!! Gimmie!

0:30 – Wow, I have the beta downloaded already. This is going to be epic.

0:38 – “Go Online”??? but I’m online now. What gives? Oh well – I’ll play along.

1:00 – OK, a list of hotfixes. I would have thought since the installer is running on my machine it would know what I have and don’t have, and could just give me a list.

3:10 – So out of all those hotfixes 2 were already installed, and one failed to install. Lets try and install IE again and see what happens.

3:30 – the IE9 beta installer still thinks I’m offline, when I’m not. I’m guessing get updates is going to take me right back to where I was. Lets try something else.

4:22 – Hmm..This file that the failed IE9 installer put on my desktop mentions a second install location that has all the files that are required to install IE9 if the computer is not connected to the internet. That sounds promising.

5:45 – Wireless is slow.

6:50 – the ‘nothing more to download’ installer seems to still be trying to download something and failing in the same way. I’ve seen this movie before.

Lets Try To Install IE9 Beta from Joseph Cooney on Vimeo.

So it looks like my inability to install KB2259539 is blocking me from installing IE9. Maybe the IE9 team have just made the best possible case for web apps, which circumvent all this crap? I, for one, welcome our new HTML5 overlords.

Re-watching the video I noticed I inadvertently skipped installing one of the pre-requisites listed on one of those pages (KB2120976). When I installed this it said it was already installed.

Comments are closed